カテゴリ:FreeBSD( 20 )

FreeBSD 6.3 に PostgreSQL 8.3 を入れた。
FreeBSD 6.3 にPostgreSQL 8.3 を入れた。

PostgreSQL83-Server のディレクトリに移動して、
make install clean
と打ち込んでオプションを適当に選んでOKするとコンパイルが始まる。
コンパイルが終わるのを待つ。

コンパイルが終わったら、

/usr/local/etc/rc.d/postgresql initdb

More
[PR]

by arigayas | 2008-06-07 06:23 | FreeBSD | Trackback | Comments(0)
FreeBSD FirefoxにおいてLinuxバイナリプラグインを使う方法 nspluginwrapper
記事へのリンク:http://gihyo.jp/admin/clip/01/fdt/200801/11


FreeBSDに触れる時に使う時用のメモです。


www/nspluginwrapper

ports - FreeBSD FirefoxにおいてLinuxバイナリで提供されている各種プラグイン(Flash 7,Flash 9,Adobe Reader 7/8,Realplayer)を活用する方法にnspluginwrapper(www/nspluginwrapper)を使う方法があります。

プラグインがアップデートされた場合にはnspluginwrapperのほうもアップデート処理を実施する必要があります。たとえば最近 Adobe Reader 8が導入されたり,Flash 7/9のportがアップグレードされたわけですが,そうったタイミングで再度nspluginwrapperを実行します。

いちいち手動でアップデートするのは面倒なので,次のようなスクリプトを作成しておいて,プラグインが動作しなくなった場合に実行するようにしておくと便利です。

Flash 9の動作はあまり安定していません。Adobeから正式なFreeBSD版Flash 9の提供が期待されるところです。

nspluginwrapperを使ってLinuxプラグインを活用するためのスクリプトは、本記事を参照されたし。
[PR]

by arigayas | 2008-01-12 02:59 | FreeBSD | Trackback | Comments(0)
fusefs-ntfs 1.710_1
Options for fusefs-ntfs 1.710_1
[X] LOCK Lock the device when mounting (avoids access)
[X] UBLIO Enable user space cache for improved speed

Windows Files System -> NTFS
[PR]

by arigayas | 2007-10-25 00:14 | FreeBSD | Trackback | Comments(0)
beep-media-player-0.9.7.1_2,1
OPTIONS= VORBIS "Enable Ogg Vorbis support" on
ESOUND "Enable Esound support" off
3DNOW "Enable 3DNow! optimized decoding routines" on
IPV6 "Enable IPv6 support" off

More
[PR]

by arigayas | 2007-09-15 00:36 | FreeBSD | Trackback | Comments(0)
xmms-1.2.10_10

Xmms supports Gzipped and uncompressed skins. If you would like to use
Zip format skins you will need to ensure archivers/unzip is installed.
===> Compressing manual pages for xmms-1.2.10_10
===> Running ldconfig
/sbin/ldconfig -m /usr/local/lib
===> Registering installation for xmms-1.2.10_10
===> SECURITY REPORT:
This port has installed the following files which may act as network
servers and may therefore pose a remote security risk to the system.
/usr/local/bin/xmms
/usr/local/lib/xmms/Input/libmpg123.so

If there are vulnerabilities in these programs there may be a security
risk to the system. FreeBSD makes no guarantee about the security of
ports included in the Ports Collection. Please type 'make deinstall'
to deinstall the port if this is a concern.

For more information, and contact details about the security
status of this software, see the following webpage:
http://www.xmms.org/
===> Cleaning for libmikmod-esound-3.1.11_2
===> Cleaning for xmms-1.2.10_10
[PR]

by arigayas | 2007-09-14 22:01 | FreeBSD | Trackback | Comments(0)
gcc-4.2.2
===> Running ldconfig
/sbin/ldconfig -m /usr/local/lib/gcc-4.2.2
===> Installing ldconfig configuration file
===> Registering installation for gcc-4.2.2_20070905
===> SECURITY REPORT:
This port has installed the following files which may act as network
servers and may therefore pose a remote security risk to the system.
/usr/local/lib/gcc-4.2.2/libmudflapth.so.0
/usr/local/lib/gcc-4.2.2/libmudflap.so.0

If there are vulnerabilities in these programs there may be a security
risk to the system. FreeBSD makes no guarantee about the security of
ports included in the Ports Collection. Please type 'make deinstall'
to deinstall the port if this is a concern.

For more information, and contact details about the security
status of this software, see the following webpage:
http://gcc.gnu.org/
===> Cleaning for libgmp-4.2.1_2
===> Cleaning for mpfr-2.3.0
===> Cleaning for gcc-4.2.2_20070905
[PR]

by arigayas | 2007-09-13 07:36 | FreeBSD | Trackback | Comments(0)
debug fox-1.6.29
xfc install stoped

FreeBSD# make install clean
===> Building for fox-1.6.29
Making all in utils
c++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"fox\" -DVERSION=\"1.6.29\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_DIRENT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_GETPAGESIZE=1 -DHAVE_MMAP=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_SELECT_H=1 -DHAVE_SYS_FILIO_H=1 -DHAVE_X11_EXTENSIONS_SHAPE_H=1 -DHAVE_X11_EXTENSIONS_XSHM_H=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZLIB_H=1 -DHAVE_X11_XCURSOR_XCURSOR_H=1 -DHAVE_X11_EXTENSIONS_XRANDR_H=1 -DHAVE_VSSCANF=1 -DHAVE_VSNPRINTF=1 -DHAVE_STRTOLL=1 -DHAVE_STRTOULL=1 -I. -I. -I/usr/local/include -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/local/include -O2 -fno-strict-aliasing -pipe -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations -DHAVE_XFT_H=1 -D_THREAD_SAFE -I/usr/local/include -I/usr/local/include/freetype2 -DHAVE_XSHAPE_H=1 -DHAVE_XSHM_H=1 -DFOX_THREAD_SAFE=1 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -D_GNU_SOURCE -DHAVE_JPEG_H=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZ2LIB_H=1 -DHAVE_XCURSOR_H=1 -DHAVE_XRANDR_H=1 -DNO_XIM -Wall -W -Woverloaded-virtual -Wformat -O2 -fno-strict-aliasing -pipe -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations -DNDEBUG -Wuninitialized -pg -DHAVE_GLU_H=1 -DHAVE_GL_H=1 -I/usr/local/include -c reswrap.cpp
c++: -pg and -fomit-frame-pointer are incompatible
*** Error code 1

Stop in /usr/ports/x11-toolkits/fox16/work/fox-1.6.29/utils.
*** Error code 1

Stop in /usr/ports/x11-toolkits/fox16/work/fox-1.6.29.
*** Error code 1

Stop in /usr/ports/x11-toolkits/fox16.
*** Error code 1

Stop in /usr/ports/x11-toolkits/fox16.

Makefile
[PR]

by arigayas | 2007-09-12 22:25 | FreeBSD | Trackback
gtkpod 0.99.10_1
Options for gtkpod 0.99.10_1
[X] MPEG4IP Enable AAC and H.264 support with MPEG4IP
[X] VORBIS Enable Ogg/Vorbis support
[X] FLAC Enable FLAC support
[X] GNOMEVFS Enable iPod autodetection support
[X] HAL Enable HAL support
[X] CURL Build with coverart download support


===> SECURITY REPORT:
This port has installed the following files which may act as network
servers and may therefore pose a remote security risk to the system.
/usr/local/bin/gtkpod

If there are vulnerabilities in these programs there may be a security
risk to the system. FreeBSD makes no guarantee about the security of
ports included in the Ports Collection. Please type 'make deinstall'
to deinstall the port if this is a concern.

For more information, and contact details about the security
status of this software, see the following webpage:
http://www.gtkpod.org/
[PR]

by arigayas | 2007-09-11 23:45 | FreeBSD | Trackback | Comments(0)
無線LANを有効化
ここを参考にやってみた。
[PR]

by arigayas | 2007-09-11 00:28 | FreeBSD | Trackback | Comments(0)
[FreeBSD] libintl.so.6 is not found [解決]
xfce4 install for need

/libexec/ld-elf.so.1: Shared object "libintl.so.6" not found, required by "libhal.so.1"


環境は、FreeBSD 6.2-RELEASE-p4、AMD64版

Portsを更新して、ここ2週間ぐらい悩んでいた"libintl.so.6" not found,が解決できた。
/usr/local/lib
libintl.so.8があったのでこれにリンクを張れば良いのかな?と思い実行してみたら、見事にビンゴ!!
# cd /usr/local/lib
# ln -s libintl.so.8 libintl.so.6

これで色々できるようになりそうだ。

不要かもしれないけど、書いておこう
ln -s libintl.so.8(実際にあるファイル名) libintl.so.6(リンク元の名前)
[PR]

by arigayas | 2007-09-09 00:49 | FreeBSD | Trackback | Comments(2)