Firefox 2.0.0.6,1をmake したら出たエラー。
CDに焼いた FreeBSD 6.2 リリース ( AMD 64 )を入れた。(パッケージ/アプリは入れず)
その後に
portsnap で ports を更新して
Freebsd-update をしてFreeBSDのセキュリティを上げた後に

Xwindow(X.org 7.2)を入れて、
WindowMakerを入れ、
Firefox 2を入れようとしたら出た。
An older version of www/firefox is already installed (firefox-1.5.0.8,1)
You may wish to ''make deinstall'' and install this port again
by ''make reinstall'' to upgrade it properly.
If you really wish to overwrite the old port of www/firefox
without deleting it first, set the variable "FORCE_PKG_REGISTER"
in your environment or the "make install" command line.

まずは何しよう。


追記

いつ入れたか覚えていない Firefox 1.5.0.8,1 が原因でエラーになったので Firefox 2.0.0.6,1 にする方法を調べた。
結論は、
# portupgrade -lv Firefox
だった。

portupgrade コマンドをする為の知っておくべきこととして、
  1. su コマンドでスーパーユーザーになってから
  2. portupgrade をインストールしておく。
  3. portsnap コマンドでportsを更新しておく
  4. pkg_version -v -l \< で更新する必要があるか確認する
  5. あれば、portupgrade -lv アプリ名でアップデートする


> portsnap コマンドでportsを更新しておく
portsnap fetch で portsの圧縮データ(目次データ?)を取ってくる。
portsnap extract で portsnap fetch で取ってきた圧縮データを展開。
portsnap update で ports の更新。

2回目以降は、
portsnap fetch && portsnap update でOKらしい。
[PR]

by arigayas | 2007-09-01 16:07 | FreeBSD | Trackback | Comments(0)
トラックバックURL : http://arigayas.exblog.jp/tb/7379986
トラックバックする(会員専用) [ヘルプ]
※このブログはトラックバック承認制を適用しています。 ブログの持ち主が承認するまでトラックバックは表示されません。
<< FreeBSDのメモ - pk... Bug-jp 4833 書き直し >>